Announcement

Collapse
No announcement yet.

WiFi Shield not working (help!)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • WiFi Shield not working (help!)

    Hi guys, I am very new to the PHPoC WiFi Shield so I don't really have much experience with it.

    I tried connecting my PHPoC WiFi Shield to my laptop and although the light is on for "ON", the light for status and wifi are turned off.
    The shield was working yesterday and after I uploaded some new codes onto it, it stopped working the next day.

    Is there anyway possible to reset the shield? I tried connecting the shield to the debugger but it can't recognise the shield, I also tried pressing the reset and setup button but nothing is working.

    Please help! Thanks!

  • #2
    Hello there,

    Since you made changes on the shield's flash files, I think you may be trying to do flash files reset.
    The answer is yes, but you will need to connect the shield to the debugger to do so.

    Note that the RESET button is for rebooting the shield, while the SETUP button is used for put the shield in Setup mode.
    https://www.phpoc.com/support/manual..._en_180515.pdf

    I find it quite stranger if ON led is on while others are off.
    It may happen if you accidentally enter ISP mode on PHPoC shield.

    But first, let's forget about it.
    Try to stop supplying and then supply power again to Arduino board. Make sure SETUP and RESET buttons on your shield are not being stuck.

    If you can see the STATUS led blink, then it means PHPoC shield is back to normal mode.
    You may not need to reset the shield at all!

    But yep, if you insist on doing that , try to connect the shield with the debugger again (remember to keep supplying power to Arduino board).
    After a successful connection, go to Function --> System Information --> Flash files --> Check for update.
    It will do the flash files reset on the shield.
    The rest will be a piece of cake to you

    Cheers

    Comment


    • #3
      Thanks Homer!

      I tried connecting the shield with the debugger but the debugger could not even recognise the COM, only the ON led is on and status and wifi led are still off...

      Does that mean my PHPoC shield is completely destroyed?

      Comment


      • #4
        Well, if the STATUS LED is still off, then I am afraid that your shield can not work anymore.
        Make sure you use the proper power supply, and did not break any part on the shield or Arduino.
        Let's check if all the pins are plugged properly between the shield and Arduno, and Arduino board works normally or not.

        And the last try: keep pressing SETUP button, unplug and then plug the power supply for Arduino. Now release the button and check if the debugger can recognize the COM port of the shield or not.
        If it can recognize the COM port, then there is still hope.
        Who knows? Maybe a miracle will happen, otherwise you probably need a new shield
        Cheers

        Comment


        • #5
          Homer you absolute life saver! It's connecting to the debugger!

          However I'm still unable to make any changes as the debugger says the shield is in the ISP mode... Is there any way to revert that? I tried entering initialisation mode but nothing happened...

          Thank you so much again!

          Comment


          • #6
            Ha! That's good, my friend.
            Now, thing you can try first is re-uploading firmware to your shield.
            You can find the firmware for the shield here
            https://www.phpoc.com/download.php#firmware
            Then try to connect to the debugger in that ISP mode, select File --> Upload a poc file and browse to the downloaded firmware.
            Let's see if it works this time or not
            Cheers

            Comment

            Working...
            X